EQInterface Forums

EQInterface Forums (http://www.eqinterface.com/forums/index.php)
-   Request (http://www.eqinterface.com/forums/forumdisplay.php?f=22)
-   -   Custom Spell Bar broken with recent Test Server Patch (http://www.eqinterface.com/forums/showthread.php?t=22099)

Sythik 06-13-2018 09:38 AM

Custom Spell Bar broken with recent Test Server Patch
 
I like to use a custom spell bar that shows the spell icon and the spell name with the different color spell type backgrounds. After the recent Test server patch none of the spell icons are showing in the spell bar. I tried multiple different spell bars and they were all broken now in this way. If you know of one that is working or if you can update one, thanks for the help.

Tiane 06-21-2018 02:48 AM

From here:
https://forums.daybreakgames.com/eq...n.249806/page-7

"The transparency layer in window_pieces02.tga for the spell gem holder was modified, custom UIs may need to adjust for this change.

This goes along with a change to the layer order for spell-gems where previously the colored gem-holder was rendered behind the spell image. Now the gem holder with its center set to transparent is rendered on top of the buff image to ensure a consistent outline."

Managed to get mine working again. Had to go and edit areas of the .tga's to be transparent instead of just being black. Quite the PITA.

IceSy 06-21-2018 08:05 AM

Spell Bar
 
Quote:
Originally Posted by Tiane
From here:
https://forums.daybreakgames.com/eq...n.249806/page-7

"The transparency layer in window_pieces02.tga for the spell gem holder was modified, custom UIs may need to adjust for this change.

This goes along with a change to the layer order for spell-gems where previously the colored gem-holder was rendered behind the spell image. Now the gem holder with its center set to transparent is rendered on top of the buff image to ensure a consistent outline."

Managed to get mine working again. Had to go and edit areas of the .tga's to be transparent instead of just being black. Quite the PITA.


How did you get it working? I am totally stumped! I've tried what was suggested in the EQ forums,. I've tried a few other things,. but nothing is working! :(

Savok 06-21-2018 08:24 AM

You have to modify the Alpha Channel to make the space where the Spell Gem sits to be transparent.

IceSy 06-21-2018 08:33 AM

Quote:
Originally Posted by Savok
You have to modify the Alpha Channel to make the space where the Spell Gem sits to be transparent.

I did that,. still no go. I'll triple check though. I'm running one very little sleep this past week.

AloneStarwalker 06-21-2018 01:19 PM

Spellicon is rendered
instead of:
<Holder>

under:
<Background>
<Highlight>

holder is the image it shows when you have no spell memmed.

background is that square around it.

and highlight is the mouse over highlight of that square.

so for holder we can just put any blank button graphic.

but background and highlight will now need to be custom made to fit, with proper transparency.

Tiane 06-21-2018 06:00 PM

Yup. In my case I had to make the entire centre of a_spellgembackground transparent where before it was just black (and thus usually transparent on most older TGA uses, but DBG decided to get all strict.)

You can do it with photoshop or gimp or whatever. Just look at the code in equi_castspellwnd.xml and see what .tga file is being referenced, and the x and y coords for the icon. Load it up in an editor, find the area, then make it transparent in the middle.

Same goes for a_spellgemhighlight (or whatever your .xml file calls it), needs to be transparent in the middle.

Worst case, for testing, you can copy the definitions from the equi_animations.xml file as placeholders so you can see where your particular problem lies. i.e. rem out whatever definition is in that spot and paste in:

Code:
<Ui2DAnimation item="insert_custom_spellgembackround_name_here"> <Frames> <Texture>window_pieces02.tga</Texture> <Location> <X>209</X> <Y>177</Y> </Location> <Size> <CX>39</CX> <CY>32</CY> </Size> </Frames> </Ui2DAnimation>


Which is the spot in the newly modified window_pieces02 where DBG has their transparent spell gem background.

BalforH 06-22-2018 02:52 AM

1 Attachment(s)
Howdy All

Well I found a work around that might help, I edited the window_pieces02.tga. See attached image

And this is the holder, background, highlight I am using

<SpellGem item="CSPW_Spell0">
<ScreenID>CSPW_Spell0</ScreenID>
<RelativePosition>true</RelativePosition>
<Location>
<X>0</X>
<Y>0</Y>
</Location>
<Size>
<CX>110</CX>
<CY>30</CY>
</Size>
<SpellGemDrawTemplate>
<Holder>A_BtnPressed</Holder>
<Background>A_SpellGemBackground</Background>
<Highlight>A_SpellGemHighlight</Highlight>
</SpellGemDrawTemplate>
<SpellIconOffsetX>4</SpellIconOffsetX>
<SpellIconOffsetY>4</SpellIconOffsetY>
</SpellGem>

Now IceSy I know your spellbar isnt as wide as mine so you may have to tweak the image to fit.

EQDAB 06-22-2018 03:41 AM

A great bunch of talent on this site!!
 
Quote:
Originally Posted by BalforH
Howdy All

Well I found a work around that might help, I edited the window_pieces02.tga. See attached image

And this is the holder, background, highlight I am using

<SpellGem item="CSPW_Spell0">
<ScreenID>CSPW_Spell0</ScreenID>
<RelativePosition>true</RelativePosition>
<Location>
<X>0</X>
<Y>0</Y>
</Location>
<Size>
<CX>110</CX>
<CY>30</CY>
</Size>
<SpellGemDrawTemplate>
<Holder>A_BtnPressed</Holder>
<Background>A_SpellGemBackground</Background>
<Highlight>A_SpellGemHighlight</Highlight>
</SpellGemDrawTemplate>
<SpellIconOffsetX>4</SpellIconOffsetX>
<SpellIconOffsetY>4</SpellIconOffsetY>
</SpellGem>

Now IceSy I know your spellbar isnt as wide as mine so you may have to tweak the image to fit.

Quite a generous :) designer, thanks from all :nana:

Sythik 06-22-2018 10:15 AM

I downloaded Balfor Compilations but what specific files are needed to get just the spell bar working? Thanks.

Fariona 06-23-2018 03:40 AM

Is there any easy fix for this? I don't make Uis and only understand some of what you guys are saying. But I need this fixed

Jinaabi3169 07-17-2018 12:06 PM

Basically, the problem is that originally the spell icon was rendered on top of whatever graphics you have put in the button. Now, the spell gem is rendered on the bottom of all of the graphics. Since there is no way to affect what level the gem renders, you have to make a 'hole' or 'window' in the graphic to see the icon through. That means modifying the image file that contains the graphics for the 'button' (typically WindowsPieces02.tga, but could be anywhere if you use a custom UI).

If you are not adept at modifying tga files, your only options are to find a cast window that has this fixed, or maybe post your UI and see if you can get someone to fix it for you.


All times are GMT -5. The time now is 02:01 AM.

vBulletin Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.