Thread: Ang's UI
View Single Post
Old 11-19-2016, 12:57 AM   #138
Tobynn
A Ghoul
 
Join Date: Dec 2002
Posts: 15
Default Hero's Forge

Greetings Ang !

Discovered an oddity related to Hero's Forge ornaments (Type 21). Unable to left- or right-click on the ornaments to remove them from ItemDisplay. Also, the text label adjacent to the ornament box has gone missing from ItemDisplay. This is not a brand new occurrence; I noticed it couple months ago but as may only swap out these type 21s once every few months, I cannot say when it first cropped up. Meant to mention it upon discovery but forgot until now! I can swap to default UI and functionality is normal.

I did a fresh install using your latest download and still no dice.

I took a peek at your Magelo profile and I see you are not using Heros Forge type 21s, so likely something you may not be able to verify, visually.

edit#1: After more screwing around with it, I did eventually discover that there is sweet spot (at the very bottom) within the ornament slot about 1x10 pixels whereupon the tooltip does display on mouse hover. You can right- or left-click within that mini sweet spot and remove the ornament. Label still invisible though

edit#2: The plot thickens. Heh. I suspect the clickable region is being offset for certain classes due to the RACE field in ItemDisplay being either one -or- two lines of text. Example: My druid has click problems, my necro has click problems, my warrior has no click problem whatsoever. They all use the same install of AngUI.

Examples from ItemDisplay:

CLASS: WAR
RACE: HUM BAR ELF DEF HEF DWF TRL OGR
HFL GNM IKS VAH FRG DRK
(two lines of text)

CLASS: DRU
RACE: HUM ELF HEF HFL DRK
(one line of text)

CLASS: NEC
RACE: HUM ERU DEF GNM IKS FRG DRAK
(one line of text)

The absent line of text causes a shift upwards, resulting in the clickable region on those two classes being nestled waaaay down at the bottom edge of the slot and obscuring the text label.

At least that's my best guess, Ang !!
Tobynn is offline   Reply With Quote