Home Forum Downloads My Favorites Register FAQ Mark Forums Read

Go Back   EQInterface Forums > Developer Discussion > XML modification help.
User Name
Password

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-17-2017, 07:40 PM   #1
finchy
A Gray Wolf
 
Join Date: Apr 2015
Posts: 5
Default Inventory adjustment

Hello,

I am trying to adjust a few items on the inventory window on a custom UI i've been using where the creator hasn't updated in awhile. I will do my best to explain, but i'm very new to this whole thing, so please bare with me.


The first thing I am trying to change is in the stats window, being able to show the 2 AC numbers, mitigation and evasion. The current stats page of the UI i'm using only shows the single AC number prior to the update.

Using the default inventory.xml file i simply copied and pasted that section to overwrite the section for AC. Below is a copy/paste of that.


The first piece below is directly from the default EQUI_Inventory.xml file:

<Label item="IWS_CurrentMitigation">
<EQType>22</EQType>
<RelativePosition>true</RelativePosition>
<Location>
<X>58</X>
<Y>0</Y>
</Location>
<Size>
<CX>55</CX>
<CY>14</CY>
</Size>
<Text>0</Text>
<TextColor>
<R>255</R>
<G>255</G>
<B>255</B>
</TextColor>
<NoWrap>true</NoWrap>
<AlignCenter>false</AlignCenter>
<AlignRight>true</AlignRight>
<AlignLeft>false</AlignLeft>
<TooltipReference>Mitigation: Chance to take less melee damage</TooltipReference>
</Label>
<Label item="IWS_ACDivider">
<RelativePosition>true</RelativePosition>
<Location>
<X>115</X>
<Y>0</Y>
</Location>
<Size>
<CX>5</CX>
<CY>14</CY>
</Size>
<Text>/</Text>
<TextColor>
<R>255</R>
<G>255</G>
<B>255</B>
</TextColor>
<NoWrap>true</NoWrap>
<AlignCenter>false</AlignCenter>
<AlignRight>false</AlignRight>
</Label>
<Label item="IWS_Evasion">
<EQType>403</EQType>
<RelativePosition>true</RelativePosition>
<Location>
<X>120</X>
<Y>0</Y>
</Location>
<Size>
<CX>55</CX>
<CY>14</CY>
</Size>
<Text>0</Text>
<TextColor>
<R>255</R>
<G>255</G>
<B>255</B>
</TextColor>
<NoWrap>true</NoWrap>
<AlignCenter>false</AlignCenter>
<AlignRight>false</AlignRight>
<AlignLeft>true</AlignLeft>
<TooltipReference>Evasion: Chance to avoid melee damage</TooltipReference>



This second section is directly out of the same file, but from the custom UI i've been using:

<Label item="IWS_CurrentArmorClass">
<EQType>22</EQType>
<RelativePosition>true</RelativePosition>
<Font>2</Font>
<Location>
<X>80</X>
<Y>0</Y>
</Location>
<Size>
<CX>75</CX>
<CY>14</CY>
</Size>
<Text>0</Text>
<TextColor>
<R>255</R>
<G>255</G>
<B>255</B>
</TextColor>
<NoWrap>true</NoWrap>
<AlignCenter>false</AlignCenter>
<AlignRight>true</AlignRight>
<AlignLeft>false</AlignLeft>


After I copied the first part here to overwrite the second section. I saved it, and reloaded the UI. Apparently it didn't like it because it broke the entire UI and set every window to default, with no custom anything.

I'm sure i've completely fubared this, but hoping that someone could point me in the right direction on how to correct this? If i need to provide anything extra please let me know.


Thanks for any help that can be provided.
finchy is offline   Reply With Quote
 



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:22 AM.


vBulletin Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
© MMOUI