EQInterface Forums

EQInterface Forums (http://www.eqinterface.com/forums/index.php)
-   Help ! ? ! ? (http://www.eqinterface.com/forums/forumdisplay.php?f=16)
-   -   EQUI_CastSpellWnd.xml spellbook btn (http://www.eqinterface.com/forums/showthread.php?t=22076)

erfg12 01-10-2018 08:02 AM

EQUI_CastSpellWnd.xml spellbook btn
I cannot get the spellbook button to appear on EQUI_CastSpellWnd.xml

I uploaded the skin UI I'm working on at https://github.com/erfg12/titanium-classicui

There is some sample code with a working spellbook button, but I can't get it working on mine. Here's the sample theme: http://neondawg.com/~Reg/eq/classic.rar

EQUI_CastSpellWnd.xml ...

<Button item="CSPW_SpellBook"> <ScreenID>CSPW_SpellBook</ScreenID> <!--<Font>3</Font>--> <RelativePosition>true</RelativePosition> <Location> <X>-1</X> <Y>318</Y> </Location> <Size> <CX>18</CX> <CY>11</CY> </Size> <Style_Transparent>false</Style_Transparent> <TooltipReference>Opens and closes Your Spellbook</TooltipReference> <Style_Checkbox>true</Style_Checkbox> <!--<RadioGroup/>--> <ButtonDrawTemplate> <Normal>A_BookBtnNormal</Normal> <Pressed>A_BookBtnPressed</Pressed> <Flyby>A_BookBtnFlyby</Flyby> <Disabled>A_BookBtnDisabled</Disabled> <PressedFlyby>A_BookBtnPressedFlyby</PressedFlyby> </ButtonDrawTemplate> </Button> <Screen item = "CastSpellWnd"> ......... <Pieces>CSPW_SpellBook</Pieces> ......... </Screen>

EQUI_Animations.xml ...
<Ui2DAnimation item = "A_BookBtnNormal"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>181</X> <Y>61</Y> </Location> <Size> <CX>22</CX> <CY>22</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation>

It looks correct to me. No errors present in UIErrors.txt

Sparxx 01-10-2018 10:53 AM


Try changing the X and Y to 0 (zero)

See if it shows. If it does (mind you it may be behind something else), then you will need to put in the correct Loc's.

erfg12 01-10-2018 01:15 PM

I tried making the size 100x100 so I could see it even if it was hidden behined something, I also tried 0 0 position and 100 0 and moving the castspellwindow around to see if it was peaking around some other position, but still nothing.

UPDATE: Ok, looks like if I click where 0 0 would be, it opens the spellbook! So that's good. Not 100% sure why the spellbook image isn't showing.

Can I put CSPW_SpellBook piece in another .xml or does it have to be in EQUI_CastSpellWnd.xml?

UPDATE2: I grabbed another window_pieces01.tga from another skin and poof it appeared! Strange, I opened the original window_pieces01.tga with photoshop and it didn't appear to be corrupt or anything... not 100% sure why that happened. O well. Thanks for the help!

Sparxx 01-11-2018 09:56 AM

Originally Posted by erfg12
Thanks for the help!

You bet, glad you got it resolved :)

erfg12 01-11-2018 12:48 PM

Quick question. Can I somehow make the spellbook open via a button programmed in to a different .xml file?

All times are GMT -5. The time now is 06:42 PM.

vBulletin Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.