Home Forum Downloads My Favorites Register FAQ Mark Forums Read

Go Back   EQInterface Forums > General Discussion > Request
User Name
Password

Reply
 
Thread Tools Display Modes
Old 04-26-2013, 01:17 PM   #16
Halelen
Manaetic Prototype IX
 
Join Date: Jan 2003
Server: Povar
Posts: 937
Interface Author - Click to view interfaces
Default

Yeah you need to adjust the loc in your fills that loc tells it where at in the window pieces to find the image.will look at it more when I get home.
Halelen is offline   Reply With Quote
Old 04-26-2013, 02:19 PM   #17
Halelen
Manaetic Prototype IX
 
Join Date: Jan 2003
Server: Povar
Posts: 937
Interface Author - Click to view interfaces
Default

Code:
<Gauge item="Player_HP"> <ScreenID>PlayerHP</ScreenID> <TextColor> <R>240</R> <G>240</G> <B>240</B> </TextColor> <RelativePosition>true</RelativePosition> <TextOffsetX>-155</TextOffsetX> <GaugeOffsetY>44</GaugeOffsetY> <FillTint> <R>240</R> <G>240</G> <B>240</B> </FillTint> <EQType>1</EQType> <GaugeDrawTemplate> <Background>A_GaugeBackground</Background> <Fill>A_GaugeFill</Fill> <!--<Lines>A_GaugeLines</Lines>--> <EndCapLeft>A_GaugeEndCapLeft</EndCapLeft> <EndCapRight>A_GaugeEndCapRight</EndCapRight> </GaugeDrawTemplate> <AutoStretch>true</AutoStretch> <TopAnchorOffset>0</TopAnchorOffset> <BottomAnchorOffset>54</BottomAnchorOffset> <LeftAnchorOffset>0</LeftAnchorOffset> <RightAnchorOffset>0</RightAnchorOffset> <RightAnchorToLeft>false</RightAnchorToLeft> </Gauge> <Ui2DAnimation item = "A_GaugeBackground_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>0</X> <Y>0</Y> <---- is your gauge really at 0,0 on windows pieces 1.tga?? </Location> <Size> <CX>138</CX> <----- is the gauge in windows pieces 1 really this size..i think you are confusing this and the declares for the size you want it drawn in the xml <CY>12</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item="A_GaugeFill0_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>0</X> <Y>43</Y> <----- ok according to this if I open your window_pieces1.tga the fill bar will be located at 0, 43...is this the actual location? </Location> <Size> <CX>138</CX> <CY>12</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item = "A_GaugeFill1_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>-6762</X> <Y>43</Y> </Location> <Size> <CX>10000</CX> <CY>12</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item = "A_GaugeFill2_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>-9762</X> <Y>43</Y> </Location> <Size> <CX>10000</CX> <CY>12</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Gauge item = "PW_Gauge1A"> <RelativePosition>true</RelativePosition> <Location> <X>0</X> <Y>0</Y> </Location> <Size> <CX>3100</CX> <CY>13</CY> </Size> <GaugeOffsetX>-6900</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>240</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill1_PW</Fill> </GaugeDrawTemplate> </Gauge> <Screen item="PW_Gauge1A_X"> <RelativePosition>true</RelativePosition> <Location> <X>6</X> <Y>43</Y> </Location> <Size> <CX>69</CX> <CY>13</CY> </Size> <Style_Transparent>true</Style_Transparent> <Pieces>PW_Gauge1A</Pieces> </Screen> <Gauge item = "PW_Gauge1B"> <RelativePosition>true</RelativePosition> <Location> <X>100</X> <Y>43</Y> </Location> <Size> <CX>42</CX> <CY>13</CY> </Size> <GaugeOffsetX>-96</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>240</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill</Fill> </GaugeDrawTemplate> </Gauge> <Gauge item = "PW_Gauge2A"> <RelativePosition>true</RelativePosition> <Location> <X>0</X> <Y>0</Y> </Location> <Size> <CX>100</CX> <CY>13</CY> </Size> <GaugeOffsetX>-9900</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill2_PW</Fill> </GaugeDrawTemplate> </Gauge> <Screen item="PW_Gauge2A_X"> <RelativePosition>true</RelativePosition> <Location> <X>6</X> <Y>43</Y> </Location> <Size> <CX>137</CX> <CY>13</CY> </Size> <Style_Transparent>true</Style_Transparent> <Pieces>PW_Gauge1A</Pieces> </Screen> <Gauge item = "PW_Gauge2B"> <RelativePosition>true</RelativePosition> <Location> <X>140</X> <Y>43</Y> </Location> <Size> <CX>2</CX> <CY>13</CY> </Size> <GaugeOffsetX>-136</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill</Fill> </GaugeDrawTemplate> </Gauge> <Gauge item = "PW_Gauge3"> <RelativePosition>true</RelativePosition> <Location> <X>6</X> <Y>43</Y> </Location> <Size> <CX>138</CX> <CY>13</CY> </Size> <GaugeOffsetX>0</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>0</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Lines>A_GaugeLines</Lines> </GaugeDrawTemplate> </Gauge>






Here are a few more clues and I cant adjust these cause I don't know the locs on your window pieces 1 or if you use a custom animations file.

Last edited by Halelen : 04-26-2013 at 02:50 PM.
Halelen is offline   Reply With Quote
Old 04-26-2013, 04:51 PM   #18
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

Sorry, I just don't know how to figure that out.

I use a custom window_pieces01, its the same as default on gauges but changed the background to be somewhat transparent to see thru the background when not filled. I do not use a custom animations file.
I will attach my file for you.
Attached Files
File Type: zip window_pieces01.zip (38.7 KB, 13 views)
__________________
Stice
Stice is offline   Reply With Quote
Old 04-26-2013, 08:41 PM   #19
warriorofmight
Enhanced Imperial Golem
 
Join Date: Aug 2004
Posts: 230
Interface Author - Click to view interfaces
Default

Tried to play around with it some but just don't have the time to really go into it. However, if you check the default animations file, you'll find the correct loc for Gauge fill. Your current locs are off. By adjusting the locs, I was able to get solid bars. That's as far as I got, but then fubared the file and deleted it shortly after

In a normal color change window, as the health bar depletes, the colors change. You start with, say green, then at 75 you change to yellow, then at 50 orange, then at 25 red.

However, you are attempting to basically make it change where the whole thing is grey, then red at 99%, then yellow at 75%, then gray again at 50%. Feels like maybe you're missing a layer.

Also, once you get it working on player health, you're basically going ot have to completely flip all the sizes and offsets in order to make it work in reverse for the aggro meter ... this seems like an ambitious task and I hope you crack this!
__________________

Oink! Reborn

Last edited by warriorofmight : 04-26-2013 at 08:47 PM.
warriorofmight is offline   Reply With Quote
Old 04-26-2013, 09:52 PM   #20
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

what was trying to do is grey to 69%, yellow from 70% to 99%, and red at 100%. i thought I was doing that correct, guess it is back to the drawing board =(
Stice is offline   Reply With Quote
Old 04-26-2013, 10:22 PM   #21
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

ok thank you Warriorofmight for telling me where to fing locs for my gauge and fill. this is the default one the one i use so updated it looks like this now.
Whats next? =)
Code:
<Gauge item="Player_HP"> <ScreenID>PlayerHP</ScreenID> <TextColor> <R>240</R> <G>240</G> <B>240</B> </TextColor> <RelativePosition>true</RelativePosition> <TextOffsetX>-155</TextOffsetX> <GaugeOffsetY>44</GaugeOffsetY> <FillTint> <R>240</R> <G>240</G> <B>240</B> </FillTint> <EQType>1</EQType> <GaugeDrawTemplate> <Background>A_GaugeBackground</Background> <Fill>A_GaugeFill</Fill> <!--<Lines>A_GaugeLines</Lines>--> <EndCapLeft>A_GaugeEndCapLeft</EndCapLeft> <EndCapRight>A_GaugeEndCapRight</EndCapRight> </GaugeDrawTemplate> <AutoStretch>true</AutoStretch> <TopAnchorOffset>0</TopAnchorOffset> <BottomAnchorOffset>54</BottomAnchorOffset> <LeftAnchorOffset>0</LeftAnchorOffset> <RightAnchorOffset>0</RightAnchorOffset> <RightAnchorToLeft>false</RightAnchorToLeft> </Gauge> <Ui2DAnimation item = "A_GaugeBackground_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>108</X> <Y>7</Y> </Location> <Size> <CX>100</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item="A_GaugeFill0_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>108</X> <Y>18</Y> </Location> <Size> <CX>100</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item = "A_GaugeFill1_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>-6762</X> <Y>43</Y> </Location> <Size> <CX>10000</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item = "A_GaugeFill2_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>-9762</X> <Y>43</Y> </Location> <Size> <CX>10000</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Gauge item = "PW_Gauge1A"> <RelativePosition>true</RelativePosition> <Location> <X>0</X> <Y>0</Y> </Location> <Size> <CX>3100</CX> <CY>13</CY> </Size> <GaugeOffsetX>-6900</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>240</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill1_PW</Fill> </GaugeDrawTemplate> </Gauge> <Screen item="PW_Gauge1A_X"> <RelativePosition>true</RelativePosition> <Location> <X>6</X> <Y>43</Y> </Location> <Size> <CX>69</CX> <CY>13</CY> </Size> <Style_Transparent>true</Style_Transparent> <Pieces>PW_Gauge1A</Pieces> </Screen> <Gauge item = "PW_Gauge1B"> <RelativePosition>true</RelativePosition> <Location> <X>100</X> <Y>43</Y> </Location> <Size> <CX>42</CX> <CY>13</CY> </Size> <GaugeOffsetX>-96</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>240</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill</Fill> </GaugeDrawTemplate> </Gauge> <Gauge item = "PW_Gauge2A"> <RelativePosition>true</RelativePosition> <Location> <X>0</X> <Y>0</Y> </Location> <Size> <CX>100</CX> <CY>13</CY> </Size> <GaugeOffsetX>-9900</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill2_PW</Fill> </GaugeDrawTemplate> </Gauge> <Screen item="PW_Gauge2A_X"> <RelativePosition>true</RelativePosition> <Location> <X>6</X> <Y>43</Y> </Location> <Size> <CX>137</CX> <CY>13</CY> </Size> <Style_Transparent>true</Style_Transparent> <Pieces>PW_Gauge1A</Pieces> </Screen> <Gauge item = "PW_Gauge2B"> <RelativePosition>true</RelativePosition> <Location> <X>140</X> <Y>43</Y> </Location> <Size> <CX>2</CX> <CY>13</CY> </Size> <GaugeOffsetX>-136</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill</Fill> </GaugeDrawTemplate> </Gauge> <Gauge item = "PW_Gauge3"> <RelativePosition>true</RelativePosition> <Location> <X>6</X> <Y>43</Y> </Location> <Size> <CX>138</CX> <CY>13</CY> </Size> <GaugeOffsetX>0</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>0</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Lines>A_GaugeLines</Lines> </GaugeDrawTemplate> </Gauge>
Stice is offline   Reply With Quote
Old 04-27-2013, 09:06 AM   #22
Halelen
Manaetic Prototype IX
 
Join Date: Jan 2003
Server: Povar
Posts: 937
Interface Author - Click to view interfaces
Default

ill look at it today and see whats going on...I also may have some bad news ..iirc during beta I tried to mess with the agro gauge and I believe that the color was hardcoded and could not be changed so you may have some issues. will post results in a few.
Halelen is offline   Reply With Quote
Old 04-27-2013, 10:37 AM   #23
Halelen
Manaetic Prototype IX
 
Join Date: Jan 2003
Server: Povar
Posts: 937
Interface Author - Click to view interfaces
Default

Ok first chance I have had to look at it and play with it in game..you have your math all wrong. so start by editing out all the layers and start 1 at a time. First for the gray it doesn't need to be a layer just change the regular bar color to be gray . then add in the first layer your math is all wrong remember that the offset is 10000 - % - gauge length. now that you have that you can change 10000 to 13800 if you want as was suggested. remember for the first layer you want the cover to be 60% and the actual countdown 39%..once you get that working add second layer you want cover to 99% and countdown 1%. I have some things to do but will check in on you later.


Hal
Halelen is offline   Reply With Quote
Old 04-27-2013, 02:15 PM   #24
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

Do I need to change it to 13800 or can it stay at 10000?
Why does the first one need to be 60% with a 39% countdown? is that how it gets changed at 70% to yellow?

Quote:
First for the gray it doesn't need to be a layer just change the regular bar color to be gray

Not sure what you mean, I am just using the reg
<Gauge item="Player_HP"> and it is set to 240/240/240

Also i am still a bit confused on how to figure out the X location on the 1b and 2b. where you said a bit ago on this thread...
not sure why this is to 140 yet so I can figure out the 2nd gauge.
<Location>
<X>133</X> <---you would want this to be 140

it seems to me the B gauges are all correct can you tell me if they are so i can just leave them alone if needed.

I also was told to tell you.. I am a mentally and physically challenged person with OCD too. I have Asperger syndrome. the person that told me to tell you this said they were tired of me talking about this 24/7 and spending all my waking time trying to figure it out. and that i don't even play EQ now i just try to figure this out. not sure why she told me to tell you that though but i promised i would.
Stice is offline   Reply With Quote
Old 04-27-2013, 06:58 PM   #25
Halelen
Manaetic Prototype IX
 
Join Date: Jan 2003
Server: Povar
Posts: 937
Interface Author - Click to view interfaces
Default

remember your locs and sizes all need to correspond ..so if your gauge started at 6 and you have 134 size your next gauge piece would need to start at 140
Halelen is offline   Reply With Quote
Old 04-27-2013, 08:05 PM   #26
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

Do I need to change it to 13800 or can it stay at 10000?
Why does the first one need to be 60% with a 39% countdown? is that how it gets changed at 70% to yellow?
Stice is offline   Reply With Quote
Old 04-28-2013, 06:41 PM   #27
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

Well I got the 1st gauge to work correct by doing a math error.
As you told me..
70% of 13800 = the offset 9660 -138= 9522 this didn't work for me for my A_GaugeFill1_PW CX location , it looked like the red does now.
I didn't take 138 off the 9660 I took off by mistake 108 and came up with 9552 and it filled in perfect. Oddly enough the 1a gauge size is <CX>4140</CX> (30%)and the <GaugeOffsetX>-9660</GaugeOffsetX>(70%) Still.

The 2nd gauge seems to not follow the same rule, is that because i just want a red cover and with just 1 point of health gone and it goes yellow?

I changed it all to 13800 sized and from what i understand what you have told me how to do this have this.. I also noted from what you just told me my gauge started at 4 not 6 and adjusted it. the gauge looks just the same as before. i also changed the 2nd gauge to be just 1 pixel wide. attached photo to show how it looks now.
it feels like i am getting stuck right now and don't know what to do.

Seems to me that 2b is almost useless if I do not want it to show up. and can i just make the size of the screen to the full gauge so when i get the correct X numbers for 2a and my 2nd offset just one hit and red disappears?
if I set them like below would it just not show up till 100% at all?

<Screen item="PW_Gauge2A_X">
<Size>
<CX>138</CX>
<CY>13</CY>
</Size>
<Pieces>PW_Gauge2A</Pieces>
</Screen>

<Gauge item = "PW_Gauge2B">
<Location>
<X>142</X>
<Y>43</Y>
</Location>
<Size>
<CX>0</CX>
<CY>13</CY>
</Size>
<GaugeOffsetX>-138</GaugeOffsetX>


Thank you for helping me.

Code:
<Gauge item="Player_HP"> <ScreenID>PlayerHP</ScreenID> <TextColor> <R>240</R> <G>240</G> <B>240</B> </TextColor> <RelativePosition>true</RelativePosition> <TextOffsetX>-155</TextOffsetX> <GaugeOffsetY>44</GaugeOffsetY> <FillTint> <R>240</R> <G>240</G> <B>240</B> </FillTint> <EQType>1</EQType> <GaugeDrawTemplate> <Background>A_GaugeBackground</Background> <Fill>A_GaugeFill</Fill> <!--<Lines>A_GaugeLines</Lines>--> <EndCapLeft>A_GaugeEndCapLeft</EndCapLeft> <EndCapRight>A_GaugeEndCapRight</EndCapRight> </GaugeDrawTemplate> <AutoStretch>true</AutoStretch> <TopAnchorOffset>0</TopAnchorOffset> <BottomAnchorOffset>54</BottomAnchorOffset> <LeftAnchorOffset>0</LeftAnchorOffset> <RightAnchorOffset>0</RightAnchorOffset> <RightAnchorToLeft>false</RightAnchorToLeft> </Gauge> <Ui2DAnimation item = "A_GaugeBackground_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>108</X> <Y>7</Y> </Location> <Size> <CX>100</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item="A_GaugeFill0_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>108</X> <Y>18</Y> </Location> <Size> <CX>100</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item = "A_GaugeFill1_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>-9552</X> <Y>18</Y> </Location> <Size> <CX>13800</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Ui2DAnimation item = "A_GaugeFill2_PW"> <Cycle>true</Cycle> <Frames> <Texture>window_pieces01.tga</Texture> <Location> <X>-13524</X> <Y>18</Y> </Location> <Size> <CX>13800</CX> <CY>10</CY> </Size> <Hotspot> <X>0</X> <Y>0</Y> </Hotspot> <Duration>1000</Duration> </Frames> </Ui2DAnimation> <Gauge item = "PW_Gauge1A"> <RelativePosition>true</RelativePosition> <Location> <X>0</X> <Y>0</Y> </Location> <Size> <CX>4140</CX> <CY>13</CY> </Size> <GaugeOffsetX>-9660</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>240</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill1_PW</Fill> </GaugeDrawTemplate> </Gauge> <Screen item="PW_Gauge1A_X"> <RelativePosition>true</RelativePosition> <Location> <X>4</X> <Y>43</Y> </Location> <Size> <CX>96</CX> <CY>13</CY> </Size> <Style_Transparent>true</Style_Transparent> <Pieces>PW_Gauge1A</Pieces> </Screen> <Gauge item = "PW_Gauge1B"> <RelativePosition>true</RelativePosition> <Location> <X>100</X> <Y>43</Y> </Location> <Size> <CX>42</CX> <CY>13</CY> </Size> <GaugeOffsetX>-96</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>240</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill</Fill> </GaugeDrawTemplate> </Gauge> <Gauge item = "PW_Gauge2A"> <RelativePosition>true</RelativePosition> <Location> <X>0</X> <Y>0</Y> </Location> <Size> <CX>138</CX> <CY>13</CY> </Size> <GaugeOffsetX>-13662</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill2_PW</Fill> </GaugeDrawTemplate> </Gauge> <Screen item="PW_Gauge2A_X"> <RelativePosition>true</RelativePosition> <Location> <X>4</X> <Y>43</Y> </Location> <Size> <CX>137</CX> <CY>13</CY> </Size> <Style_Transparent>true</Style_Transparent> <Pieces>PW_Gauge2A</Pieces> </Screen> <Gauge item = "PW_Gauge2B"> <RelativePosition>true</RelativePosition> <Location> <X>141</X> <Y>43</Y> </Location> <Size> <CX>1</CX> <CY>13</CY> </Size> <GaugeOffsetX>-137</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>240</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Fill>A_GaugeFill</Fill> </GaugeDrawTemplate> </Gauge> <Gauge item = "PW_Gauge3"> <RelativePosition>true</RelativePosition> <Location> <X>4</X> <Y>43</Y> </Location> <Size> <CX>138</CX> <CY>13</CY> </Size> <GaugeOffsetX>0</GaugeOffsetX> <GaugeOffsetY>0</GaugeOffsetY> <Text></Text> <TextOffsetY>8000</TextOffsetY> <Style_VScroll>false</Style_VScroll> <Style_HScroll>false</Style_HScroll> <Style_Transparent>false</Style_Transparent> <!--<TooltipReference/>--> <FillTint> <R>0</R> <G>0</G> <B>0</B> </FillTint> <LinesFillTint> <R>0</R> <G>0</G> <B>0</B> </LinesFillTint> <DrawLinesFill>false</DrawLinesFill> <EQType>1</EQType> <GaugeDrawTemplate> <Lines>A_GaugeLines</Lines> </GaugeDrawTemplate> </Gauge>
Attached Images
File Type: jpg closer.jpg (56.8 KB, 4 views)

Last edited by Stice : 04-29-2013 at 04:04 PM.
Stice is offline   Reply With Quote
Old 04-30-2013, 07:09 PM   #28
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

a side note, I did change the yellow over to the aggro in the player window and it works there just fine. quickly found out the aggro % was 75% and not 70% so tried to change and did not work for 75%.

Could this be something about default gauges not working for this?
Stice is offline   Reply With Quote
Old 05-02-2013, 01:46 AM   #29
Stice
A Snow Griffin
 
Join Date: Feb 2003
Posts: 55
Interface Author - Click to view interfaces
Default

Did a few tests and made a new .tga file with just the gauge on it and had it go 254 pixels wide. changed out the animations to use that file and now it works perfect. thank you so much for all the help!!
BTW the default gauge does not seem to want to go over a unknown to me amount ATM. I have a 138 pixel gauge and wanted it 96 and 137 for the back fill and it just wouldn't do that, your gauge is 110 wide and 88 pixels of back fill must be right around that max. I could be wrong but I have tried MANY things to make it work and just stretching out the gauge on the .tga was the only thing that would work for me. wish was some way not to use the animations.xml to make my new tga gauge work but oh well i got it to work.

thanks again.
Stice is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:52 PM.


vBulletin Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
© MMOUI