Home Forum Downloads My Favorites Register FAQ Mark Forums Read

Go Back   EQInterface Forums > General Discussion > Help ! ? ! ?
User Name
Password

Reply
 
Thread Tools Display Modes
Old 09-19-2006, 03:53 PM   #1
bellvar
A Ghoul
 
Join Date: Feb 2004
Posts: 19
Default Tablets UI - Need help Updating for TSS

Hello,

Is anyone still working on this UI or expecting to update it for TSS support?

Thanks for your Time,

Bellvar
bellvar is offline   Reply With Quote
Old 09-19-2006, 05:25 PM   #2
qdrago
A Ghoul
 
Join Date: May 2005
Posts: 16
Default

i hope someone can update it=(
qdrago is offline   Reply With Quote
Old 09-20-2006, 09:26 AM   #3
TBHockey
A Gray Wolf
 
Join Date: Feb 2004
Posts: 6
Default

I am trying to fix this UI, I have it working up through PoR but have had issues with TSS, It may take me some time because I am not very experienced in XML but am in other languages. I will update the site when i get it running. Unless or course someone more experienced is working on this.
TBHockey is offline   Reply With Quote
Old 09-20-2006, 11:44 AM   #4
mulluane
A Snow Cougar
 
Join Date: Dec 2002
Server: drinal
Posts: 45
Default

Oh bless you!
mulluane is offline   Reply With Quote
Old 09-20-2006, 12:22 PM   #5
Brighid741
A Tempest Toad
 
Brighid741's Avatar
 
Join Date: Feb 2004
Server: The Seventh Hammer
Posts: 463
Interface Author - Click to view interfaces
Default

Thank you TB. I was going to take a stab at it next week when I have some time but I don't know XML either so I'm sure I'd be spinning my wheels a great deal.
Brighid741 is offline   Reply With Quote
Old 09-20-2006, 05:46 PM   #6
Macinstine
A Ghoul
 
Join Date: Jul 2003
Server: tunare
Posts: 12
Default

Be sure to delete the filgre form your updates it makes a right mess of tablets
Macinstine is offline   Reply With Quote
Old 09-21-2006, 07:53 AM   #7
Tanvarien
A Treant
 
Join Date: Aug 2002
Server: Xegony
Posts: 24
Default Anyone having any luck?

I made modifications myself when PoR came out and was able to keep using Tablets, but this time it's kicking my butt. I know next to nothing about it, though I'm starting to learn quite a bit. Symbol Table error (I'm guessing this has to do with the EQUI_Animations file) and Filigrees are driving me nuts.
__________________
Tanvarien Panteras
Ring of Truth
Xegony Server
Tanvarien is offline   Reply With Quote
Old 09-21-2006, 08:28 AM   #8
TBHockey
A Gray Wolf
 
Join Date: Feb 2004
Posts: 6
Default

Tanv,
Same with me, I got it working through PoR but having the same issues, I just don't have tons of time to spend on it. Wish I could hire and XML Programmer to fix this.
TBHockey is offline   Reply With Quote
Old 09-21-2006, 01:32 PM   #9
Brighid741
A Tempest Toad
 
Brighid741's Avatar
 
Join Date: Feb 2004
Server: The Seventh Hammer
Posts: 463
Interface Author - Click to view interfaces
Default

Same here

I started editing the changed files last night using the compares that are posted here. The one big problem I'm still getting is the error validating symbol table - I read that if you copy the EQUI_Animiations.xml file from default it gets rid of that error so I did that and in fact that error is gone but it now won't load tablets again.

I've only updated the first 3 files though so it may work once I get through all of the changed files. I won't be able to work on it again until next week *cry*.

I hope someone can get it working again.

I don't know XML either. I only know a little HTML - pretty much just the basics - but I have messed with the tablets files before. When my mana and hp both went over 10k they didn't fit in the Actions window any more so I tweaked it in small increments until they fit.
Brighid741 is offline   Reply With Quote
Old 09-21-2006, 01:44 PM   #10
Tanvarien
A Treant
 
Join Date: Aug 2002
Server: Xegony
Posts: 24
Default

Well I know from toying with it you can't just copy the EQUI_Animations file over because you'll lose all the Tablets specific graphic references. Also can't do a direct compare and add in items that are missing because Tablets actually breaks the EQUI_Animations file into multiple smaller animation files (all the anim_*.xml files) then the main animations file just includes all the smaller ones. The changes to the buffs for adding the new yellow background buffs that don't effect OOC regen have to be made in the anim_buffs.xml file. I'm going to try and work on this some more tonight. I thought I had all the necessary animation changes, but to be honest I did some cut and paste and was in a bit of a hurry so I might have made mistakes along the way. This is kind of fun learning how things work, but sure is a lot of work for the layman.
Tanvarien is offline   Reply With Quote
Old 09-21-2006, 01:48 PM   #11
mareeuh
A Shissar Disciple
 
Join Date: Oct 2002
Posts: 118
Default

Be sure to delete the filgre form your updates it makes a right mess of tablets


Where specifically can I find and fix the Filigree issue? It's the only thing aside from player window that I can't update.

Mareeuh
mareeuh is offline   Reply With Quote
Old 09-21-2006, 01:59 PM   #12
Tanvarien
A Treant
 
Join Date: Aug 2002
Server: Xegony
Posts: 24
Default

I believe (and again this is layman poking around) that the Filigree issue has to do with any windows that don't have tablet specific customization. Take the new reward window for example (I don't know if it has filigree just using for example). There isn't an xml file for that window in Tablets so it uses the one in default. That is ok, but if the default one uses the WDT_Filigree template it won't find it because Tablets doesn't define one. Sorry, if that doesn't make sense or if I'm completely off, but I'm pretty sure that's the problem from some files I was looking at this morning.
Tanvarien is offline   Reply With Quote
Old 09-21-2006, 04:41 PM   #13
mulluane
A Snow Cougar
 
Join Date: Dec 2002
Server: drinal
Posts: 45
Default

This is the fix they are refering to. I remember it causing huge problems.

http://www.eqinterface.com/forums/s...ead.php?t=17668
mulluane is offline   Reply With Quote
Old 09-21-2006, 07:31 PM   #14
Brighid741
A Tempest Toad
 
Brighid741's Avatar
 
Join Date: Feb 2004
Server: The Seventh Hammer
Posts: 463
Interface Author - Click to view interfaces
Default

Quote:
Originally Posted by Tanvarien
Well I know from toying with it you can't just copy the EQUI_Animations file over because you'll lose all the Tablets specific graphic references.

yeah I found that out the hard way.

Quote:
Originally Posted by Tanvarien
Also can't do a direct compare and add in items that are missing because Tablets actually breaks the EQUI_Animations file into multiple smaller animation files (all the anim_*.xml files) then the main animations file just includes all the smaller ones.

Yeah I haven't gotten to that section yet - just the EQUI and AA windows and for both of those I stayed in line with what was already in the files just made tweaks to load the new files in the EQUI and the AA window copied tab 11 and changed to tab 12 on all instances of tab 11 then changed the name.

Quote:
Originally Posted by Tanvarien
The changes to the buffs for adding the new yellow background buffs that don't effect OOC regen have to be made in the anim_buffs.xml file. I'm going to try and work on this some more tonight. I thought I had all the necessary animation changes, but to be honest I did some cut and paste and was in a bit of a hurry so I might have made mistakes along the way. This is kind of fun learning how things work, but sure is a lot of work for the layman.

I agree, it's very cool to see how it all comes together but it is a PITA. I didn't even notice the yellow background - I haven't really played since the release 'cause I've been messing with UI's and working LOL.
Brighid741 is offline   Reply With Quote
Old 09-21-2006, 07:32 PM   #15
Brighid741
A Tempest Toad
 
Brighid741's Avatar
 
Join Date: Feb 2004
Server: The Seventh Hammer
Posts: 463
Interface Author - Click to view interfaces
Default

Quote:
Originally Posted by mulluane
This is the fix they are refering to. I remember it causing huge problems.

http://www.eqinterface.com/forums/s...ead.php?t=17668

Awesome, thank you for the link now I know what to take out!
Brighid741 is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:10 PM.


vBulletin Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
© MMOUI